RE: BGP dampening

From: Echo Chan (echo.chan@xxxxxxxxx)
Date: Sat Aug 28 1999 - 05:48:01 GMT-3


   
Hi All,

I had successfully simulated route dampening by using three 2501 routers.

The physical connection of the three router are as follows:
Router1 (s0) <--> Router2 (s0)
Router2 (s1) <--> Router3 (s0)
Router3 (e0) <--> Router1 (e0)

The simplified configuration of the three routers:

Router1
hostname router1
!
interface Ethernet0
 ip address 3.0.3.1 255.255.255.0 secondary
 ip address 1.0.1.1 255.255.255.0
!
interface Serial0
 ip address 10.0.100.1 255.255.255.0
!
router bgp 701
 bgp dampening
 network 1.0.0.0
 neighbor 1.0.1.3 remote-as 703
 neighbor 10.0.100.2 remote-as 702
!
**********************************

Router2
hostname router2
!
interface Ethernet0
 ip address 2.0.2.2 255.255.255.0
!
interface Serial0
 ip address 10.0.100.2 255.255.255.0
!
router bgp 702
 bgp dampening
 network 2.0.0.0
 neighbor 10.0.100.1 remote-as 701
 neighbor 172.0.200.3 remote-as 703
!
***********************************

Router3
hostname router3
!
interface Ethernet0
 ip address 1.0.1.3 255.255.255.0 secondary
 ip address 3.0.3.3 255.255.255.0
!
interface Serial0
 ip address 172.0.200.3 255.255.255.0
!
router bgp 703
 bgp dampening
 network 3.0.0.0
 neighbor 1.0.1.1 remote-as 701
 neighbor 172.0.200.2 remote-as 703
 neighbor 172.0.200.2 route-map ADVERT-OUT out
!
route-map ADVERT-OUT permit 10
 set as-path prepend 703
************************

In router3:
router3# clear ip bgp *
and wait 1 minutes ( unit all neighbor state is established )

Then, remove the route-map ADVERT-OUT out by:
router3(config-router)#no neighbor 172.0.200.2 route-map ADVERT-OUT out
router3(config-router)#end
router3# clear ip bgp *

***********************

go to router2:

router2#sh ip bgp
BGP table version is 79, local router ID is 172.0.200.2
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
* 1.0.0.0 172.0.200.3 0 703 701 i
*> 10.0.100.1 0 0 701 i
*> 2.0.0.0 0.0.0.0 0 32768 i
*> 3.0.0.0 172.0.200.3 0 0 703 i
*d 10.0.100.1 0 701 703 i
router2#

Best Regards,
Chan Wai Sun
UUNET Hong Kong -
An MCI WorldCom Company

-----Original Message-----
From: Dave Oakman [mailto:doakman@home.com]
Sent: Friday, August 27, 1999 8:04 AM
To: 'ccielab@groupstudy.com'
Subject: BGP dampening

Has anyone had luck with BGP dampening? I am attempting a simple config to
see the effects of dampening but am having no luck.

I know that dampening occurs only with ebgp peers so I shutdown the
switchport that is connected to my router simulate an external line failure
, but for some crazy reason the line/protocol on my 4500 stays up (keepalive
10). So I tried it over a serial link did a shut down and showed bgp routes
just disappeared with no dampening or history stats.

Am I just missing something stupid ??

Thanks
TTFN
DaveO
6 days and counting



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:47 GMT-3