The case of the mystery IPX tunnel: Where did the bits go ?

From: Jason Aarons (jaarons@xxxxxxxxxxx)
Date: Mon Aug 16 1999 - 19:10:26 GMT-3


   
Minn <----------> Iowa <--------> Florida
IPX Tunnel IP Tunnel IPX
B001 CAD B001

Version 11.3(10)T

While the IPX RIP packets appear to be sent to Tunnel, it looks like they
never make it though the tunnel. Packets get out tunnel but never in
tunnel!

hostname florida
!
ipx routing 0010.7be8.00f6
!
interface Tunnel0
no ip address
ipx network CAD
tunnel source Serial0
tunnel destination 192.168.1.1
!
interface Ethernet0
ip address 30.0.0.1 255.255.255.0
ipx network B003
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
!
interface Serial1
no ip address
shutdown
!
END

hostname minn
!
ipx routing 0010.7b3b.1e30
!
interface Tunnel0
no ip address
ipx network CAD
tunnel source Serial0
tunnel destination 192.168.2.2
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
ipx network B001
!
interface Serial0
ip address 192.168.1.1 255.255.255.0
!
END

florida#ping 10.0.0.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/5/8 ms

florida#debug ipx routing activity
IPX routing debugging is on
02:30:28: IPXRIP: positing full update to CAD.ffff.ffff.ffff via Tunnel0
(broadc
ast)
02:30:28: IPXRIP: Update len 40 src=CAD.0010.7be8.00f6,
dst=CAD.ffff.ffff.ffff(4
53)
02:30:28: network B003, hops 1, delay 151
02:30:28: IPXRIP: positing full update to B003.ffff.ffff.ffff via Ethernet0
(bro
adcast)
02:30:28: IPXRIP: Update len 40 src=B003.0010.7be8.00f6,
dst=B003.ffff.ffff.ffff
(453)
02:30:28: network CAD, hops 1, delay 2

minn#debug ipx routing act
IPX routing debugging is on
minn#
02:32:55: IPXRIP: positing full update to CAD.ffff.ffff.ffff via Tunnel0
(broadc
ast)
02:32:55: IPXRIP: Update len 40 src=CAD.0010.7b3b.1e30,
dst=CAD.ffff.ffff.ffff(4
53)
02:32:55: network B001, hops 1, delay 151
02:32:58: IPXRIP: positing full update to B001.ffff.ffff.ffff via Ethernet0
(bro
adcast)
02:32:58: IPXRIP: Update len 40 src=B001.0010.7b3b.1e30,
dst=B001.ffff.ffff.ffff
(453)
02:32:58: network CAD, hops 1, delay 2

florida#show ipx route
Codes: C - Connected primary network, c - Connected secondary network
       S - Static, F - Floating static, L - Local (internal), W - IPXWAN
       R - RIP, E - EIGRP, N - NLSP, X - External, A - Aggregate
       s - seconds, u - uses, U - Per-user static

2 Total IPX routes. Up to 1 parallel paths and 16 hops allowed.

No default route known.

C CAD (TUNNEL), Tu0
C B003 (NOVELL-ETHER), Et0

florida#show int tunnel0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set, keepalive set (10 sec)
  Tunnel source 192.168.2.1 (Serial0), destination 192.168.1.1
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Checksumming of packets disabled, fast tunneling enabled
  Last input never, output 00:00:12, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     230 packets output, 12032 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
minn#show int tunnel0
Tunnel0 is up, line protocol is up
  Hardware is Tunnel
  MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation TUNNEL, loopback not set, keepalive set (10 sec)
  Tunnel source 192.168.1.1 (Serial0), destination 192.168.2.2
  Tunnel protocol/transport GRE/IP, key disabled, sequencing disabled
  Checksumming of packets disabled, fast tunneling enabled
  Last input never, output 00:00:23, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/0, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     223 packets output, 11406 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 output buffer failures, 0 output buffers swapped out
minn#

florida#debug tunnel
Tunnel Interface debugging is on
florida#
02:37:26: Tunnel0: GRE/IP encapsulated 192.168.2.1->192.168.1.1
(linktype=11, le
n=64)

minn#debug tunnel
Tunnel Interface debugging is on
minn#term mon
minn#
02:39:53: IPXRIP: positing full update to CAD.ffff.ffff.ffff via Tunnel0
(broadc
ast)
02:39:53: IPXRIP: Update len 40 src=CAD.0010.7b3b.1e30,
dst=CAD.ffff.ffff.ffff(4
53)
02:39:53: network B001, hops 1, delay 151
02:39:53: Tunnel0: GRE/IP encapsulated 192.168.1.1->192.168.2.2
(linktype=11, le
n=64)
02:39:56: IPXRIP: positing full update to B001.ffff.ffff.ffff via Ethernet0
(bro
adcast)
02:39:56: IPXRIP: Update len 40 src=B001.0010.7b3b.1e30,
dst=B001.ffff.ffff.ffff
(453)
02:39:56: network CAD, hops 1, delay 2

----Original Message Follows----
From: Cisco Technical Assistance Center <tac@cisco.com>
Reply-To: lalew@cisco.com
To: jaarons@professionalnetworks.com
Subject: Status Change for Cisco Case V26028

CASE: V26028
TITLE: 2610: IPX tunneling failing
PRIORITY: 3
STATUS: Cust-Pend

Jason. Aarons,

This is a Customer Case Update Notification from Cisco Systems regarding
Case
Number V26028, which you opened with the Cisco Technical Assistance Center.

Case V26028 has been changed to a status of Cust-Pend. This status
indicates th
e Cisco Customer Service Engineer assigned to your case
has requested information from you and is awaiting your response. No
workaround
for your case has been determined at this time.

Since this is a Priority 3 case, you will receive ongoing email notification
until it is closed. Priority 1 and 2 case notifications occur every 24
hours,
Priority 3 every 72 hours (3 days), Priority 4 every 120 hours (5 days).

Larry Lew is the Customer Support Engineer at Cisco who owns your case
V26028. If you need to discuss this case further, Larry Lew can be
reached by email at lalew@cisco.com or by phone at 408 526-6643 .

You can also reach Larry Lew or the Cisco Technical Assistance Center
through the following methods:

    North America: 1-800-553-2447
    Europe: 32-2-704-5555
    Asia Pacific: 61-2-9935-4107
    Australia: 1-800-805-227
    USA Non-Domestic: 1-408-526-7209

To disable these email notifications or to update or check the status of
your case over the Internet using Cisco Connection Online (CCO), registered
CCO users may point their web browser to:

     http://www.cisco.com/kobayashi/Tech_support.shtml

Sincerely,

Technical Assistance Center
Cisco Systems, Inc.



This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:46 GMT-3