From: Fred Ingham (fningham@xxxxxxxxxxxxxxxx)
Date: Wed Jul 28 1999 - 00:52:28 GMT-3
You don't say what the four spoke interface types (could be physical or
point-to-point) but in general: All serial interfaces in the cloud
must be the same OSPF network type. And the spokes should be configured
with ospf priority 0 so they are ineligible to be DR or BDR. A sample
configuration with three routers r1 (hub) r2,r4 (spokes), neighbor
statements only on r1:
***** R1 is the hub using a multipoint interface
Current configuration:
!
version 11.2
!
hostname r1
!
interface Serial0
no ip address
encapsulation frame-relay
bandwidth 64
!
interface Serial0.1 multipoint
ip address 150.100.33.1 255.255.255.0
frame-relay map ip 150.100.33.2 102 broadcast
frame-relay map ip 150.100.33.4 104 broadcast
!
router ospf 1
network 150.100.33.0 0.0.0.255 area 0
neighbor 150.100.33.4
neighbor 150.100.33.2
!
r1#sh ip ospf nei
Neighbor ID Pri State Dead Time Address
Interface
150.100.33.4 0 FULL/DROTHER 00:01:42 150.100.33.4
Serial0.1
150.100.33.2 0 FULL/DROTHER 00:01:57 150.100.33.2
Serial0.1
***** R2 is a spoke using a point-to-point subinterface
Current configuration:
!
version 11.3
no service password-encryption
!
hostname r2
!
enable password xxxxx
!
interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
bandwidth 64
no fair-queue
!
interface Serial0.1 point-to-point
ip address 150.100.33.2 255.255.255.0
ip ospf network non-broadcast
ip ospf priority 0
frame-relay interface-dlci 201
!
router ospf 2
network 150.100.33.0 0.0.0.255 area 0
!
end
r2#sh ip ospf nei
Neighbor ID Pri State Dead Time Address
Interface
150.100.33.1 1 FULL/DR 00:01:40 150.100.33.1
Serial0.1
***** R4 is a spoke using a physical interface
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname r4
!
enable password xxxxx
!
interface Serial0
ip address 150.100.33.4 255.255.255.0
encapsulation frame-relay
ip ospf priority 0
bandwidth 64
no fair-queue
frame-relay map ip 150.100.33.1 401 broadcast
frame-relay map ip 150.100.33.2 401 broadcast
!
router ospf 4
network 150.100.33.0 0.0.0.255 area 0
!
r4#sh ip ospf nei
Neighbor ID Pri State Dead Time Address
Interface
150.100.33.1 1 FULL/DR 00:01:42 150.100.33.1
Serial0
Bill Carter wrote:
>
> I am configuring OSPF. 5 routers connected in a frame cloud. Routers
> 1-4 have PVC's pointing to Router 5. In other words a multi-point frame
> with Router 5 as the head end. I want to use neighbor statements. My
> frame-relay map statements do not have the broadcast option. From every
> router I can ping every WAN port.
>
> This is from a remote router:
> Neighbor Count is 1, Adjacent neighbor count is 1
> Adjacent with neighbor 150.100.50.1 (Backup Designated Router)
>
> This is from the central router
> Neighbor Count is 4, Adjacent neighbor count is 4
> Adjacent with neighbor 150.100.1.1
> Adjacent with neighbor 150.100.1.2
> Adjacent with neighbor 150.100.1.3
> Adjacent with neighbor 150.100.1.4 (Designated Router)
>
> Will this work?
> Does every router need to have neighbor statements to every other
> router?
> Is my own requirement of no broadcast in the frame-relay map statement a
> valid configuration?
>
> I would appreciate any sample configuration anyone has to offer?
>
> --
> ~~~~~~~~~~~~~~~~~~~~~~~~
> Bill Carter
> Favorite Quote
> "bodega stuck again... "
> -Cisco Bug CSCdk37204
> ~~~~~~~~~~~~~~~~~~~~~~~~
>
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:43 GMT-3