From: Mark, Detrick (mdetrick@xxxxxxxxx)
Date: Mon May 17 1999 - 20:19:28 GMT-3
Title: OSPF Trivia
View with a monospace font, like courier.
Below I have put the routing tables for the hub and spoke, along with
one of the spokes. Way below is a config for the hub.
You will notice that the gateway addresses for the spokes are
specified with a 32 bit mask, 10.0.0.2 & 10.0.0.3. I think this gets
done with the IP OSPF NETWORK POINT-TO-MULTIPOINT command. There are
2 map statements on the hub, one for each spoke. The spokes have a
map statement and are also subinterfaces of the type MULTIPOINT. When
a packet needs to be routed from dragon to the other spoke (monkey
10.0.0.3), dragon knows it needs to go out s0.1. Tiger receives the
packet and knows that 10.0.0.3 needs to go out s0.2. S0.2 gets the
packet and has mapped 10.0.0.3 to DLCI 147. Out it goes.
I hope this helps.
The routing table on the hub:
tiger#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
candidate default
U - per-user static route, o - ODR
Gateway of last resort is 10.0.0.2 to network 0.0.0.0
1.0.0.0/32 is subnetted, 8 subnets
O 1.1.1.1 [110/51] via 10.0.0.2, 21:39:43, Serial0.2
O 1.1.1.3 [110/61] via 10.0.0.2, 21:39:43, Serial0.2
[110/61] via 10.0.0.3, 21:39:43, Serial0.2
O 1.1.1.2 [110/51] via 10.0.0.3, 21:39:43, Serial0.2
i L1 1.1.1.5 [115/20] via 100.0.0.2, Serial1
C 1.1.1.4 is directly connected, Loopback0
B 1.1.1.7 [200/0] via 100.2.0.1, 20:30:26
B 1.1.1.6 [200/0] via 100.1.0.2, 20:30:26
O 1.1.1.13 [110/51] via 11.0.1.2, 21:39:43, Serial0.1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 10.0.0.2/32 [110/50] via 10.0.0.2, 21:39:44, Serial0.2
O 10.0.0.3/32 [110/50] via 10.0.0.3, 21:39:44, Serial0.2
C 10.0.0.0/24 is directly connected, Serial0.2
11.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 11.0.1.0/30 is directly connected, Serial0.1
i L1 11.1.1.0/24 [115/20] via 100.0.0.2, Serial1
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B 20.0.0.0/24 [20/0] via 10.0.0.2, 21:39:45
B 20.0.1.0/26 [20/0] via 10.0.0.2, 21:39:46
D 30.0.0.0/8 [90/409600] via 100.1.0.2, 20:30:29, Ethernet0
100.0.0.0/30 is subnetted, 4 subnets
C 100.0.0.0 is directly connected, Serial1
C 100.1.0.0 is directly connected, Ethernet0
D 100.2.0.0 [90/297728] via 100.1.0.2, 20:30:30, Ethernet0
B 100.3.0.0 [20/0] via 10.0.0.2, 20:45:45
101.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
i L1 101.9.0.0/16 [115/20] via 100.0.0.2, Serial1
i L2 101.8.0.0/13 [115/20] via 100.0.0.2, Serial1
i L1 101.10.0.0/16 [115/20] via 100.0.0.2, Serial1
O*E1 0.0.0.0/0 [110/1050] via 10.0.0.2, 21:39:48, Serial0.2
tiger#
One of my spokes...
Current configuration:
!
version 11.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname dragon
!
!
ip subnet-zero
no ip domain-lookup
!
interface Loopback0
ip address 1.1.1.2 255.255.255.255
!
interface Ethernet0
ip address 20.0.0.3 255.255.255.0
ip ospf priority 255
!
interface Serial0
no ip address
encapsulation frame-relay
no ip mroute-cache
!
interface Serial0.1 multipoint
ip address 10.0.0.3 255.255.255.0
ip ospf network point-to-multipoint
ip ospf cost 500
bandwidth 2000
frame-relay map ip 10.0.0.1 101 broadcast
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface BRI0
no ip address
shutdown
!
router ospf 1
network 20.0.0.0 0.0.0.255 area 0
network 10.0.0.0 0.0.0.255 area 5
network 1.1.1.2 0.0.0.0 area 0
area 5 virtual-link 1.1.1.4
!
router bgp 100
no synchronization
network 20.0.0.0 mask 255.255.255.0
neighbor 10.0.0.1 remote-as 200
neighbor 20.0.0.2 remote-as 100
neighbor 20.0.0.4 remote-as 100
no auto-summary
!
ip classless
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
dragon#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * -
candidate default
U - per-user static route, o - ODR
Gateway of last resort is 20.0.0.2 to network 0.0.0.0
1.0.0.0/32 is subnetted, 8 subnets
O 1.1.1.1 [110/11] via 20.0.0.2, 1d00h, Ethernet0
O 1.1.1.3 [110/11] via 20.0.0.4, 1d00h, Ethernet0
C 1.1.1.2 is directly connected, Loopback0
B 1.1.1.5 [20/20] via 10.0.0.1, 22:48:03
O 1.1.1.4 [110/501] via 10.0.0.1, 1d00h, Serial0.1
B 1.1.1.7 [200/0] via 100.3.0.2, 20:38:49
B 1.1.1.6 [20/0] via 10.0.0.1, 20:27:38
O IA 1.1.1.13 [110/111] via 20.0.0.2, 1d00h, Ethernet0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
O 10.0.0.2/32 [110/550] via 10.0.0.1, 1d00h, Serial0.1
C 10.0.0.0/24 is directly connected, Serial0.1
O 10.0.0.1/32 [110/500] via 10.0.0.1, 1d00h, Serial0.1
11.0.0.0/30 is subnetted, 1 subnets
O IA 11.0.1.0 [110/110] via 20.0.0.2, 1d00h, Ethernet0
20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 20.0.0.0/24 is directly connected, Ethernet0
B 20.0.1.0/26 [200/0] via 20.0.0.2, 22:54:26
B 30.0.0.0/8 [200/1] via 100.3.0.2, 20:41:36
100.0.0.0/30 is subnetted, 3 subnets
B 100.0.0.0 [20/0] via 10.0.0.1, 22:48:10
B 100.2.0.0 [200/0] via 100.3.0.2, 20:30:57
B 100.3.0.0 [200/0] via 20.0.0.4, 20:43:03
101.0.0.0/13 is subnetted, 1 subnets
B 101.8.0.0 [20/20] via 10.0.0.1, 22:48:12
O*E1 0.0.0.0/0 [110/1010] via 20.0.0.2, 23:37:55, Ethernet0
dragon#
Mark Detrick
DSL Business Unit
Cisco Systems
2569 McCabe Way
Irvine, CA 92614
----- Original Message -----
From: John Howell
To: 'Mark, Detrick'
Sent: Monday, May 17, 1999 3:45 PM
Subject: RE: OSPF Trivia
Do you have frame map commands on your spokes?
Thanks,
John T. Howell
Cohesive Technology Solutions
Senior Consultant/Engineer
CCNP/CCDP, MCSE+I, MCNE
225-751-6100
225-751-6200 (fax)
-----Original Message-----
From: Mark, Detrick [mailto:mdetrick@cisco.com]
Sent: Monday, May 17, 1999 5:32 PM
To: John Howell
Cc: GroupStudy (E-mail)
Subject: Re: OSPF Trivia
About below...
All my routers on the multipoint frame can communicate with each
other. Any router can be the DR. I believe that I heard that the lab
test will make you designate a spoke a DR. Beware!!!
Mark Detrick
DSL Business Unit
Cisco Systems
2569 McCabe Way
Irvine, CA 92614
----- Original Message -----
From: John Howell
To: 'Mark, Detrick'
Sent: Monday, May 17, 1999 3:25 PM
Subject: RE: OSPF Trivia
The original problem was the a spoke router was the DR and the other
spoke could not talk to it so it would loose all of its routes. I
guess with everything there is more than one way to skin a cat. Your
config and my config work and both configs would have the same problem
if a spoke was the DR.
Thanks,
John T. Howell
Cohesive Technology Solutions
Senior Consultant/Engineer
CCNP/CCDP, MCSE+I, MCNE
225-751-6100
225-751-6200 (fax)
-----Original Message-----
From: Mark, Detrick [mailto:mdetrick@cisco.com]
Sent: Monday, May 17, 1999 4:57 PM
To: John Howell
Cc: GroupStudy (E-mail)
Subject: Re: OSPF Trivia
Here it is...
http://www.cisco.com/univercd/cc/td/doc/product/software/ios112/112cg_
cr/4cbook/4cfrelay.htm
Excerpt:
Configure Dynamic or Static Address Mapping
Dynamic address mapping uses Frame Relay Inverse ARP to request the
next hop protocol address for a specific connection, given its known
DLCI. Responses to Inverse ARP requests are entered in an
address-to-DLCI mapping table on the router or access server; the
table is then used to supply the next hop protocol address or the DLCI
for outgoing traffic.
Inverse ARP is enabled by default for all protocols it supports, but
can be disabled for specific protocol-DLCI pairs. As a result, you can
use dynamic mapping for some protocols and static mapping for other
protocols on the same DLCI. You can explicitly disable Inverse ARP for
a protocol-DLCI pair if you know that the protocol is not supported on
the other end of the connection. See the "Disable or Reenable Frame
Relay Inverse ARP" section later in this chapter for more information.
Configure Dynamic Mapping
Inverse ARP is enabled by default for all protocols enabled on the
physical interface. Packets are not sent out for protocols that are
not enabled on the interface.
Because Inverse ARP is enabled by default, no additional command is
required to configure dynamic mapping on an interface.
The mapping table mentioned above is the frame map ip ... statement.
tiger#sh fram pvc
PVC Statistics for interface Serial0 (Frame Relay DTE)
DLCI = 107, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
Serial0.1
input pkts 21130 output pkts 21073 in bytes 2172488
out bytes 2189930 dropped pkts 44 in FECN pkts
0
in BECN pkts 0 out FECN pkts 0 out BECN pkts
0
in DE pkts 0 out DE pkts 0
out bcast pkts 21005 out bcast bytes 2183020
pvc create time 2d02h, last time pvc status changed 1d21h
DLCI = 127, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
Serial0.2
input pkts 11932 output pkts 13658 in bytes 821792
out bytes 995458 dropped pkts 87 in FECN pkts
0
in BECN pkts 0 out FECN pkts 0 out BECN pkts
0
in DE pkts 0 out DE pkts 0
out bcast pkts 7149 out bcast bytes 616451
pvc create time 2d02h, last time pvc status changed 1d21h
DLCI = 147, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
Serial0.2
input pkts 10256 output pkts 13069 in bytes 760632
out bytes 951685 dropped pkts 75 in FECN pkts
0
in BECN pkts 0 out FECN pkts 0 out BECN pkts
0
in DE pkts 0 out DE pkts 0
out bcast pkts 7149 out bcast bytes 616451
pvc create time 2d02h, last time pvc status changed 1d21h
tiger#
Mark Detrick
DSL Business Unit
Cisco Systems
2569 McCabe Way
Irvine, CA 92614
----- Original Message -----
From: John Howell
To: 'Mark, Detrick'
Cc: GroupStudy (E-mail)
Sent: Monday, May 17, 1999 2:38 PM
Subject: RE: OSPF Trivia
Here is a snip from the command reference and inverse-arp has nothing
to do with DLCI assignment. You can run OSPF in NON_BROADCAST or
POINT_TO_MULTIPOINT over a frame mulitpoint. Can you send me a "show
frame pvc"' for me.
frame-relay interface-dlci
To assign a data link connection identifier (DLCI) to a specified
Frame Relay subinterface on the router or access server, use the
frame-relay interface-dlci interface configuration command. Use the no
form of this command to remove this assignment.
frame-relay interface-dlci dlci [ietf | cisco] [voice-encap size]
[voice-cir cir]
no frame-relay interface-dlci dlci [ietf | cisco] [voice-encap size]
[voice-cir cir]
Syntax Description
CAPTION:
dlci
DLCI number to be used on the specified subinterface.
ietf | cisco
(Optional) Encapsulation type: Internet Engineering Task Force (IETF)
Frame Relay encapsulation or Cisco Frame Relay encapsulation.
voice-encap size
(Optional; supported on the Cisco MC3810 only.) Specifies that data
fragmentation will be used to support Voice over Frame Relay. The
voice encapsulation size denotes the data fragmentation size. The
valid range is from 80 to 1600 bytes.
For a list of recommended data fragmentation sizes and an important
note regarding the voice-encap option, see the "Usage Guidelines"
section.
voice-cir cir
(Optional; supported on the Cisco MC3810 only.) Specifies the upper
limit on the voice bandwidth that may be reserved for this DLCI. The
default is the CIR configured for the Frame Relay map class. For more
information, see the "Usage Guidelines" section.
Default
No DLCI is assigned.
Thanks,
John T. Howell
Cohesive Technology Solutions
Senior Consultant/Engineer
CCNP/CCDP, MCSE+I, MCNE
225-751-6100
225-751-6200 (fax)
-----Original Message-----
From: Mark, Detrick [mailto:mdetrick@cisco.com]
Sent: Monday, May 17, 1999 4:27 PM
To: John Howell
Cc: GroupStudy (E-mail)
Subject: Re: OSPF Trivia
Not true. I never use interface-dlci commands on my multipoint
interfaces. Inverse-arp will take care of it, which is on by default.
For OSPF you must use the IP OSPF NETWORK POINT-TO-MULTIPOINT
command. I did a sh ru for you below of a router that is acting as a
FR hub, int s0.2. Proper configuration is to have the remote routers
also configured as multipoint and also using the OSPF command. All
multipoint subinterfaces should use map and not interface-dlci.
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname tiger
!
!
ip subnet-zero
no ip domain-lookup
clns routing
!
interface Loopback0
ip address 1.1.1.4 255.255.255.255
!
interface Ethernet0
ip address 100.1.0.1 255.255.255.252
!
interface Serial0
no ip address
encapsulation frame-relay
bandwidth 2000
!
interface Serial0.1 point-to-point
ip address 11.0.1.1 255.255.255.252
bandwidth 2000
frame-relay interface-dlci 107
!
interface Serial0.2 multipoint
ip address 10.0.0.1 255.255.255.0
ip ospf network point-to-multipoint
bandwidth 2000
frame-relay map ip 10.0.0.2 127 broadcast
frame-relay map ip 10.0.0.3 147 broadcast
!
interface Serial1
ip address 100.0.0.1 255.255.255.252
ip router isis
clockrate 2000000
!
interface BRI0
no ip address
shutdown
!
router eigrp 1
network 100.0.0.0
!
router ospf 1
network 10.0.0.0 0.0.0.255 area 5
network 1.1.1.4 0.0.0.0 area 5
network 11.0.1.0 0.0.0.3 area 13
area 5 virtual-link 1.1.1.1
area 5 virtual-link 1.1.1.2
area 13 stub no-summary
!
router isis
redistribute ospf 1 metric 32 metric-type internal level-2
default-information originate
net 49.0001.0000.0000.000a.00
!
router bgp 200
no synchronization
network 100.0.0.0 mask 255.255.255.252
network 1.1.1.5 mask 255.255.255.255
network 101.8.0.0 mask 255.248.0.0
neighbor 10.0.0.2 remote-as 100
neighbor 10.0.0.3 remote-as 100
neighbor 100.1.0.2 remote-as 200
no auto-summary
!
ip classless
!
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
login
!
end
Mark Detrick
DSL Business Unit
Cisco Systems
2569 McCabe Way
Irvine, CA 92614
----- Original Message -----
From: John Howell
To: 'Mark, Detrick'
Sent: Monday, May 17, 1999 1:54 PM
Subject: RE: OSPF Trivia
Look up the command frame interface DLCI. That commands associates as
DLCI with a sub interface. By default all DLCI's are assignee to the
physical interface. You have to have that command.
Thanks,
John T. Howell
Cohesive Technology Solutions
Senior Consultant/Engineer
CCNP/CCDP, MCSE+I, MCNE
225-751-6100
225-751-6200 (fax)
-----Original Message-----
From: Mark, Detrick [mailto:mdetrick@cisco.com]
Sent: Monday, May 17, 1999 3:43 PM
To: John Howell; GroupStudy (E-mail)
Subject: Re: OSPF Trivia
Your multipoint interface needs to use maps and not interface-dlci
statements.
Mark Detrick
DSL Business Unit
Cisco Systems
2569 McCabe Way
Irvine, CA 92614
----- Original Message -----
From: John Howell
To: GroupStudy (E-mail)
Sent: Monday, May 17, 1999 1:21 PM
Subject: OSPF Trivia
I thought that I would change the subject since we have beat IPX to
death. Below is a setup for a multipoint Frame network. Why does
router R2 loose all OSPF routes when the PVC to R6 comes up? Why
does R3 and R6 maintain routes from OSPF?
R6 (hub)
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 multipoint
ip address 170.100.2.1 255.255.255.0
frame-relay interface-dlci 202
frame-relay interface-dlci 203
interface Ethernet0
ip address 170.100.70.1 255.255.255.0
router ospf 100
network 170.100.2.0 0.0.0.255 area 0
neighbor 170.100.2.3
neighbor 170.100.2.2
R2 (spoke)
interface Serial0
ip address 170.100.2.2 255.255.255.0
encapsulation frame-relay
frame-relay map ip 170.100.2.1 102 broadcast
interface Ethernet0
ip address 170.100.82.1 255.255.255.192
interface TokenRing0
ip address 170.100.81.1 255.255.255.0
router ospf 100
network 170.100.2.0 0.0.0.255 area 0
network 170.100.82.0 0.0.0.63 area 2
network 170.100.81.0 0.0.0.255 area 5
R3 (spoke)
interface Serial0
ip address 170.100.2.3 255.255.255.0
encapsulation frame-relay
frame-relay map ip 170.100.2.1 103 broadcast
interface Async1
ip address 170.100.90.1 255.255.255.248
encapsulation ppp
async default routing
async dynamic routing
async mode dedicated
interface Ethernet0
ip address 170.100.82.2 255.255.255.192
router ospf 100
network 170.100.2.0 0.0.0.255 area 0
network 170.100.82.0 0.0.0.63 area 2
network 170.100.90.0 0.0.0.7 area 3
area 3 virtual-link 170.100.101.1
Thanks,
John T. Howell
Cohesive Technology Solutions
Senior Consultant/Engineer
CCNP/CCDP, MCSE+I, MCNE
225-751-6100
225-751-6200 (fax)
This archive was generated by hypermail 2.1.4 : Thu Jun 13 2002 - 08:21:37 GMT-3